Let's Get Technical > All PREAMP Tech Tips & Support

MP-1 wierd midi problem

(1/3) > >>

So one of my 2 MP-1s is now working (sort of).  If I power it up and play, it seems to work fine.  All the front buttons work, albeit I have to press them toward the top and much harder than I remember ever having to when I used MP-1 all the time  :dunno: .  When I plug in my MXC it gets weird.  When I change to a different patch the MP-1 doesn't change straight away, seems to wait quite a long time, then change, but not always to the patch selected and the time it takes varies (display seems to flicker).  Turning volume knob to full up or down seems to get it to change (sometimes).  Even stranger is all (well most of) the front buttons stop working while the MXC is plugged in (so can't do any programing) although IIRC I can change midi channel.  If I then unplug the MXC it still stays in this weird state until I cycle the power, then it seems to work normally again (MXC unplugged).  There's nothing wrong with the MXC, it works fine with my MP-2.  Any ideas??

Hey R, I would try to swap the midi boards from one MP-1 to the other and see if that helps, if it does we can do some further fault finding. Seems the problem is there, my first guess would be the uart chip.

Hey MJMP, we tried swapping the midi boards, unfortunately that didn't help so we swapped them back.  At that point (while it was still with Tim the Tech) midi didn't seem to be working at all (with either midi boards)  :facepalm: .  Up side was we also swapped the transformers so now the working (ish) unit is 240v.  Also swapped one of the output jacks which was damaged, trying to get at least one unit working properly.  I tested some more when I got them home and I've discovered that at least that one unit works as long as I don't plug the midi switch into it.  So if it is an issue on the midi board, it appears to be on both of them.

So if I understand correctly, you have the same problem on both MP-1's or does the other mp-1 works with the MXC?

The other MP-1 (now 117v) doesn't work at all.  When Tim swapped the midi boards (as the working one wasn't responding to midi) it also didn't respond.  When we were doing a quick test at his place, as the swapped in board didn't change anything, he swapped them back.  When I got it home I had a chance to test some more.  That's when I worked out it sort of worked but not really (as described in the first post), and also stopped the front buttons working so couldn't change patch's, edit button kind of worked but up/down buttons wouldn't work.  When I unplug the midi and reboot the unit the front buttons work again,  So connecting the midi seems to put it into some sort of error state.


[0] Message Index

[#] Next page

Go to full version