ADA Depot Too - A Forum To Support Users of ADA Amplification Gear

Please login or register.

Login with username, password and session length
Advanced search  

News:

Board added for "ADA Cab Sims" in Other ADA Gear (coz El asked for it LOL)

Pages: [1]   Go Down

Author Topic: Troubles with my Lexicon Reflex  (Read 2626 times)

0 Members and 1 Guest are viewing this topic.

Peter H. Boer

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 397
  • 2* MB-1 1*MP-1 + Jur's old Mod4Mk2
    • The Granny Attic
Troubles with my Lexicon Reflex
« on: Time Format »

Hey guys,

Anyone with some technical knowledge of the Lexicon Reflex?

Mine started to make small crackling noises from time to time.
The crackling does get a nice reverb tail though, so i gather it starts before the effect processing  :???:

Peter
Logged
Nothing beats MB-1s and MP-1s with MDRTs

http://www.thegrannyattic.com
http://www.Illumion.net
http://www.sote.nl

AxeHarmony

  • Newbie
  • *
  • Offline Offline
  • Posts: 21
  • Vintage ADA = Cool
Re: Troubles with my Lexicon Reflex
« Reply #1 on: Time Format »

good quality contact cleaner dude(anything not permanently soldered like jacks, switches, pots, connectors, remember those line in/outs as sometimes the signal passes thru until you plug in to one so that internal switch contact must be clean too - be thorough and then it may be a real problem if that doesn't fix...
Logged

Sparker

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 98
Re: Troubles with my Lexicon Reflex
« Reply #2 on: Time Format »

I had one of these which developed an intermittent rumbling sound, like you would wiggle a jack plug on the input and it made a slight noise that went through the unit, but without actually having to wiggle the jack! Some folks said it was due to the SRAM chips deteriorating, but I changed those and the problem still persisted (I think it used similar/same SRAM chips as the Alesis Quadraverb, which I also had at the time). Anyway, after hours/weeks of probing and prodding I never got to the bottom of it so sold it on as spares. I have the schematics you need them.
Logged
ADA Gear: MP-1 Tube Board

MarshallJMP

  • Superhero Member
  • ******
  • Offline Offline
  • Posts: 3723
    • marshalljmpmodshop.net
Re: Troubles with my Lexicon Reflex
« Reply #3 on: Time Format »

Could also be some cracked solderjoints.
Logged
Pages: [1]   Go Up