ADA Depot Too - A Forum To Support Users of ADA Amplification Gear

Please login or register.

Login with username, password and session length
Advanced search  

News:

Lets get Technical > All Things Tube All about preamp and power amp Tubes.

Pages: [1]   Go Down

Author Topic: Replacement pots for MT200  (Read 1088 times)

0 Members and 1 Guest are viewing this topic.

calan

  • Newbie
  • *
  • Offline Offline
  • Posts: 11
    • View Profile
Replacement pots for MT200
« on: Time Format »

Can someone point me to some replacement pots for the MT200?

Values, part numbers, and a source (preferably Digikey) would be great.   ;)

*****

I may have another issue, but I think I fried the B channel pot while cleaning it. It was a bit scratchy, but working. As I was turning it back and forth to clean it up, it suddenly got very easy to turn, and the amp is now stuck in mono mode. Even when using both input and output jacks, both channels are controlled by channel A's volume pot. Otherwise, the amp still sounds fine.

« Last Edit: Time Format by calan »
Logged

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3393
    • View Profile
    • marshalljmpmodshop.net
Re: Replacement pots for MT200
« Reply #1 on: Time Format »

These are A50k pots,so 50k log.Can you post a pic so i can see what model it is?

Now the problem you have doesn't look like a pot problem.Did you clean the jacks too?
Logged

calan

  • Newbie
  • *
  • Offline Offline
  • Posts: 11
    • View Profile
Re: Replacement pots for MT200
« Reply #2 on: Time Format »

A external pic of the amp, or the internals? (It's still in the rack for the moment, but I'll yank it soon).

I didn't clean the jacks. It was hooked up in stereo and working, but with a scratchy B pot. Powered it off, cleaned the pot, felt the pot go really light, and when I turned it back on it was in mono mode. Removing and reinserting the rear plugs a few times doesn't change anything.
Logged

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3393
    • View Profile
    • marshalljmpmodshop.net
Re: Replacement pots for MT200
« Reply #3 on: Time Format »

A pic of the pots.

Again i find it strange.Seems more of a jack problem since these do the switching.
Logged

rnolan

  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 4301
    • View Profile
Re: Replacement pots for MT200
« Reply #4 on: Time Format »

Probably a good idea to change the jacks as well while you have it open, and from what MJMP says, as they do the switching (mono to stereo mode), that could well be why it's now stuck in mono.
Logged
Studio Rig: MP2/MB1 > Eurorack UB2442FX-Pro > TC M-One XL > Behringer Truths (with Truth Sub) / QUAD ESL 63s
Live Rig: MP2/MB1 > Alesis Quadverb > Alesis Midiverb 4 > Yamaha AM802 > B200s/Carvin TS100/DCM200L > ADA Split Stacks/Mesa P112s
Pages: [1]   Go Up