ADA Depot Too - A Forum To Support Users of ADA Amplification Gear

Please login or register.

Login with username, password and session length
Advanced search  

News:

Board added for "ADA Cab Sims" in Other ADA Gear (coz El asked for it LOL)

Pages: 1 [2]   Go Down

Author Topic: B200S behaving badly - blown fuses  (Read 641 times)

0 Members and 1 Guest are viewing this topic.

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #15 on: Time Format »

Yes please.
Logged
I don't feel tardy!

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #16 on: Time Format »

So I found a guy in the UK selling a BC538.  His ebay account says he is away until the 14th which was yesterday but when i sent him a message the out-of-office reply said the 19th.  I have been trying to find a compatible transistor but I am struggling because I don't know which of the specs are critical, which need to be exactly the same, which need to be at least as much and which have to be in the same ball park.  Is there another one that will do the job so that I don't have to wait until the 19th to even start to get it shipped from the other side of the planet?
Logged
I don't feel tardy!

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3478
    • View Profile
    • marshalljmpmodshop.net
Re: B200S behaving badly - blown fuses
« Reply #17 on: Time Format »

How about these?

http://www.ebay.com.au/itm/5pairs-or-10PCS-Transistor-MOTOROLA-ON-TO-92-MPS8099-MPS8599-MPS8099G-MPS8599G/401304959496?epid=738048176&hash=item5d6fa3ba08:g:RG4AAOSwc-tY6Fra
Logged

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #18 on: Time Format »

Thanks.  Don't know why that never came up in any of my searches.  :dunno:
Can't wait to get this thing back together.
I have learnt a lot about transistors.
Logged
I don't feel tardy!

Iperfungus

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 524
  • Methodical killers do good jobs!
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #19 on: Time Format »

Uhm...I've to check fuses on my B200s then: maybe B channel isn't dead!!!  :banana-dance:
Logged
On the run again!

ADA MP-1 (modified by MJMP)
Marshall JMP1
TC Electronic G Major
Alesis Quadraverb GT
Zoom 9150
Advance Tube Technologies TA '70 tube power amp
Marshall Valvestate 8008 power amp
ADA B200s power amp
Behringer FCB1010 MIDI controller
Zoom 8050 MIDI Controller
Zoom FP01 Expression pedal
Blackstar HTV 212 stereo cabinet with 70/80 Celestion speakers
Rivera Pubster 25
Blackstar Fly 3 amp + external speaker

Stomps, stomps, stomps...and stomps (Bogner rules!): TC Helix phaser, Xotic RC Booster, TC Sentry noise gate, Bogner Ecstasy Blue, Bogner Ecstasy Red, Mad Professor Royal Blue Overdrive, Sonic Research Turbo Tuner, TC Flashback delay


1987 PRS Custom
1988 Fender Strat Plus
2014 Fender Modern Player Strat
2016 Custom assembled Fender Strat
2013 Gibson SG Standard
1995 Gibson Les Paul Studio
1991 MIJ Ibanez RG570FM TB
2016 MIJ Ibanez RG655M SPM
2002 Bruno Traverso Custom "Tommy" Silky
2017 Kramer Baretta Special
2010 Simon & Patrick Woodland CW acoustic

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #20 on: Time Format »

OK. So here is the latest.
My packet of MPS8099 and 8599 transistors arrived about a week ago.  I bought heaps because I don't want to have to go through that again.  Timing was rubbish , because I haven't had an opportunity to put it all back together until today.
Everything went back in ok and when I switched it on there were no pyrotechnics.
I then played through it and the same channel was dead.  All the fuses were intact but I was getting no output.  I tried alternating the cables to eliminate dodgy cables and that was when I noticed that there was in fact some signal in that channel, just very very quiet.  I had to have the volume on that channel all the way up and I could only just hear it.  The other channel that didn't blow is behaving completely normally.
So, not all bad news, the sound was fine, just very weak.  Any ideas of where to look next?
I hope everyone had a nice Christmas.
Cheers,
Mike.
Logged
I don't feel tardy!

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3478
    • View Profile
    • marshalljmpmodshop.net
Re: B200S behaving badly - blown fuses
« Reply #21 on: Time Format »

Did you replace all the transistors?
Logged

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #22 on: Time Format »

Yep.  Five in all.
I remember testing the four big ones as they came in, but was so impatient by the time the little one arrived that I just put it straight in.  Do you think that could be it?
Logged
I don't feel tardy!

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3478
    • View Profile
    • marshalljmpmodshop.net
Re: B200S behaving badly - blown fuses
« Reply #23 on: Time Format »

Hard to tell, but since you have one side that works I would suggest measuring some voltage and compare both channel and see if something is not the same.
Logged

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #24 on: Time Format »

Cool. I'm in the process of teaching myself about electronics, so that I can understand more of what is going on and this will be an ideal project for me.
Logged
I don't feel tardy!

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3478
    • View Profile
    • marshalljmpmodshop.net
Re: B200S behaving badly - blown fuses
« Reply #25 on: Time Format »

Well this way you can check all the dc voltages, maybe you can find something since this is a dc coupled amp.
Logged

MikeB

  • Full Member
  • ***
  • Offline Offline
  • Posts: 201
    • View Profile
Re: B200S behaving badly - blown fuses
« Reply #26 on: Time Format »

I'm on it.
Step 1: Find out what "DC coupled"  means...
Logged
I don't feel tardy!

MarshallJMP

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3478
    • View Profile
    • marshalljmpmodshop.net
Re: B200S behaving badly - blown fuses
« Reply #27 on: Time Format »

Here's some more info

https://en.wikipedia.org/wiki/Direct-coupled_amplifier

http://www.andiha.no/articles/audio/dcamp.htm
Logged
Pages: 1 [2]   Go Up